How can one approximately guesstimate wave drag? [on hold]

How does wave drag compare to Induced drag and parasitic drag above Mach 1? How does it’s behavior change from Mach 1 to higher? The transonic turbulences also add a lot to the drag and whil I’m unsure what drag it is, I’d like to ask about guestimating that one as well.

All topic

Want to set bandwidth on switch ports connecting to PC’s? Can some one help me to do

enter image description here

An application running like Skype on pc should have a bandwidth of 550kb/s. And application running on pc should have 770 kb/s bandwidth and the whole switch have 2 Mb/s bandwidth limit. And skype application bandwidth should be less than 550 kb/s (reliability) if other applications are consuming for bandwidth.

All topic

USB Audio streaming Windows to Windows

Here is what I am trying to do:

D1 Laptop (Win 10) -> D2 Desktop (Win 7) -> Headphones

The last part is easy, my issue is only the audio transmission from Device1 to Device2. This means that I need a program that can run on both machines and talk to the other instance of itself, suggesting to one machine that it is an output device (speakers) and to the other that it is an input device (microphone).

There are drivers that encode and stream audio via USB (obviously), but those always require custom hardware of some sort, so I only ever get one half of the puzzle.

Does anyone know of some sort of software (virtual audio mixer, USB headphones and USB microphone drivers using the same encoding (and some way to have them talk to each other), anything really)?

Thank you <3

All topic

Please rename [winterbash-leaderboard] to [winter-bash-leaderboard]

Note the tag winterbash-leaderboard.

All of the other Winter Bash tags are winter-bash*.

Can this tag please be changed to winter-bash-leaderboard to be consistent?

(I grok that it was probably created that way to keep it under 25 characters, but as that is no longer the limit for tag names, it would be nice if it matched the others.)

All topic

Correct configuration for mail DNS when mail server sends mail, but have zoho accounts for business comms also

I’d like some help sense checking my website email and DNS set up, as well as troubleshooting one issue I have.

I have a website with a mail server installed for sending order confirmation emails. It sends emails from:

I also have a zoho account set up for:

  • My domain A record is currently pointing to my webserver.
  • My CNAME www is pointing to my webserver.
  • My CNAME mail is also pointing to my web server.
  • I have MX records pointing to zoho mail.
  • I have an SPF record as follows:

    v=spf1 ip4:<> -all

When I send emails from the website I would like to also send them to a email address. This is possible and is set to do so, however, the emails never make it through. I assume this is because the webserver sending those emails believes that resides there.

I’d also appreciate any general feedback on any misconfiguration with the above that could be done better.

All topic

Can’t access router settings

My ISP provided me a router, but they won’t let me have the credentials to access the settings (even though this is not part of the deal).

The thing is: I really need to set some stuff (daily) so I tried some passwords, but nothing happens. By that, I mean: I get no feedback on whether I’ve entered the correct or wrong pass. Besides that, right before this page render the input fields, the tab title says that I’m not authorized to access it.

In this way, I’d like to have ideas of what’s going on and if there is any way I could get my PPPoE credentials without the need to access the gateway page, so I could reset my router and set my own password.

All topic

I have a 2006 4×4 Toyota Tacoma. Brake paddle goes to floor when pushed

I changed the brake booster an bled the brakes. The back right brake bled fluid out when it was bled. All fluids are full an the vacuum lines are good. But when I push the brake paddle it goes all the way to the floor

All topic

How to get ./configure to generate defaults

In attempting to compile git under qnx, I’ve found it difficult to cleanly compile after running ./configure. I can get a much better result using the majority of the defaults.

What I’d like to find out is what the differences are between make without configure and make with configure so I can find out where configure is going wrong.

The output in configure.log hasn’t been much help so I was wondering if there is a way to generate the configure outputs without actually performing the configure process. Something that will spit out all the defaults that would be used if configure wasn’t run in the first place. I could then compare the two to find out what might be the problem.

Does anything like that exist?


All topic

Mocha test are not using port specified in ENV in Node/Express

I have a Node/Express 4x project setup using a .env file and a index.js for changing the ports and db based on how i start the app (npm start, npm run dev, etc). It works for everything except mocha test. The type of testing I’m doing is implementation test. In some of these test I make request against test databases that have their parameters defined in .env files.

If i do npm test it executes the following in my package.json:

NODE_ENV=test mocha --timeout 10000

My console.log inside my test show my host headers are always host: ' or some other random port number. In addition to that, none of the other variables in my .env are being used with npm test.

I have const app = require('../../app'); in my test suite and do not get any errors. and app.get, etc all work fine but my environment is being ignored.

npm start runs the following and works:

NODE_ENV=production node ./bin/www

npm run dev runs the following and works:

NODE_ENV=development node ./bin/www

When i change one of the above to run the NODE_ENV=test they still work and use the appropriate test related .env configurations. Yet if I run npm test mocha ignores/overrides .env. I even tried importing app as exported from bin/www to see if that made any difference and it didn’t help. I also change npm test to execute NODE_ENV=test node ./bin/www just to see if it operated as expected and it did. It’s just not using my .env when its a mocha test.

Test that don’t depend on .env being set properly (like no Mongo or SQL DB calls) work fine. Example test file:

const path = require('path');
const debug = require('debug')(`CUSTOM-DEBUG-TEST:${path.relative(process.cwd(), __dirname)}`);

// process.env.NODE_ENV = 'test';
// const app = require('../../app');
const app = require('../../bin/www');

const chai = require('chai');
const request = require('supertest');
const mongoose = require('mongoose');

const { expect } = chai;

describe('## App is online ', () => {
  it('should reply "Access API Online!" without login', (done) => {
      .end((err, res) => {
        expect(res.body.success).to.equal('Access API Online!');

Why isn’t Mocha using the ENV configuration in the same manner?

All topic

iPad has denied the launch request after update to iOS 12

I’ve been updating an application more than 5 years without problems, until yesterday.

I updated my iPad to iOS 12, but, each time I try to run it, I got the message:

iPad has denied the launch request

I tested in other physical devices with iOS 11 and simulators, and this error happens in the only iPad that I have with iOS 12.

What I tried to solve this?

  • Re-genarate my certificates in the Apple Developer.
  • Editing my schema to Debug Configuration to Release and checking and unchecking Debug executable.
  • Restart my Mac, restart the iPad.
  • Enabling and disabling Wait for executable to be launched.

And also, each solution of this thread: Xcode beta error: “iPhone has denied the launch request”

And after try of those alternative, the problem persist in the devices WITH IOS 12.

Someone has an idea about how can solve this?

All topic