HPLIP 3.18.4 upgrade

I’m trying to get the latest HPLIP 3.18.4 installed for a new printer that I purchased. My printer requires HPLIP 3.16.11 or greater and Elementary OS only provides 3.16.3 at this time.
Going through a lot of previous issues that people have had installing this software, I got mostly the way through it, but it’s still failing on 2 “missing” dependencies. I put missing in quotes because the install script says that they’re missing, but they’re both installed and on the latest versions according to Elementary.

Some other resources that helped me get this far;

How do I install the new version of HPLIP?

HPLIP Drive in Elementary

http://michael-peeters.blogspot.ca/2013/10/hp-printer-setup-under-elementary-os_20.html

    MISSING DEPENDENCIES
    --------------------
    Following dependencies are not installed. HPLIP will not work if all REQUIRED 
dependencies are not installed and some of the HPLIP features will not work if 
OPTIONAL dependencies are not installed.
    Package-Name         Component            Required/Optional   
    pil                  scan                 OPTIONAL            
    reportlab            fax                  OPTIONAL            
    libtool              base                 REQUIRED            
    dbus                 fax                  REQUIRED

This is by using the package hplip-3.18.4-run for Ubuntu. Both of the required packages show installed on my system, so I’m guessing the Elementary guys did some finagling to get this working.

Pil is Python Imaging Library and installed with “apt install python-imaging” and Reportlab is installed with “apt install python-reportlab”. After that I’m stuck with just the libtool and dbus errors that won’t let me continue.

$sudo apt list dbus
Listing... Done
dbus/xenial-updates,now 1.10.6-1ubuntu3.3 amd64 [installed]
$sudo apt list libtool
Listing... Done
libtool/xenial,xenial,now 2.4.6-0.1 all [installed]

So, why is the script complaining that they aren’t installed? How do I solve this, or trick the script into seeing that they are? Maybe a symlink not set up somewhere?

Out of curiosity I downloaded 3.16.11 thinking that’s it’s close to the same branch as what’s bundled with Elementary and it also fails on the same 2 dependencies.

Any help is greatly appreciated!

Leave a Reply

Your email address will not be published. Required fields are marked *