OAuth Error when attempting to Deploy the ApexMocks open source library in Trailhead unit ‘Apply Unit of Work…

I’m logged in to Trailhead as myself and working on this unit:
https://trailhead.salesforce.com/content/learn/modules/apex_patterns_sl/apex_patterns_sl_apply_uow_principles

Scroll to ‘Preparation for the Challenges’

Click on ‘Deploy to Salesforce’ under ‘Deploy the ApexMocks open source library’

That takes me to this page
https://githubsfdeploy.herokuapp.com/?owner=financialforcedev&repo=fflib-apex-mocks

Click on ‘Login to Salesforce’

That gives me this page
https://brave-badger-257278-dev-ed.my.salesforce.com/setup/secur/RemoteAccessErrorPage.apexp?oauth_error_code=1800

“We can’t authorize you because of an OAuth error. For more information, contact your Salesforce administrator.

1800 : There was a problem in setting up your remote access”

The first time I tried it I hadn’t launched Trailhead Playground so the login url above had the domain of my Trailhead login.

I launched Trailhead Playground and the login url then had the domain of my Trailhead Playground.

I have seen other similar questions but no conclusive explanation. I have tried it on my regular computer and also on another that has never been used for Trailhead or Salesforce before.

Any suggestions?

Leave a Reply

Your email address will not be published. Required fields are marked *