Client won an award using our product, how to mention on CV

In my last role, a client won an independent industry award using a tech start up product we developed. As part of using the product they partnered with us, but at the award ceremony due to admin error we were not joint winners.

I was a key point of contact for the client as Product manager of the Product they used, and helped them set up and launch their campaign.

Can I mention on my CV that the Product won an award via the client?

Thanks

Web app for client to alter 3D renders

I’m trying to see if there’s a web app that already exists before we go through the process of making one.

I’m looking for a way to create a render of an environment and be able to have the client click on a specific object in it (walls, a table, etc.) and change to color of it, or even swap out for a different texture. The purpose of this would be to speed up the process of the client giving notes on a design, and give them a little more creative control.

Again, I’m not sure if something like this already exists or not, and have had no luck searching on my own. If anyone knows of something like this, I’d greatly appreciate any information you could give me.


It wouldn’t need to be something this large scale in 3D, it could be a 2D image with predetermined objects in it that the client could click on and a color wheel of sorts would pop up, and they could modify that object slightly. Something more along those lines.

Lion built-in VPN client times out connecting to Windows 2003 PPTP server

I have a new iMac with OS X 10.7 (Lion) on it that refuses to connect to a PPTP-based VPN server (running Windows 2003 SBS).

To shortcut past a lot of questions: There is a Dell workstation running Windows 7 on the same LAN as the Mac that is able to establish a PPTP connection to the same VPN server using the same credentials. That would seem to rule out any possible problems with the server, the port forwards on the server’s firewall, the internet connection between the two, and the router local to the Dell and iMac.

Here’s a “verbose” dump of the PPP log from the iMac:

Tue Sep  6 10:13:11 2011 : using link 0
Tue Sep  6 10:13:11 2011 : Using interface ppp0
Tue Sep  6 10:13:11 2011 : Connect: ppp0  socket[34:17]
Tue Sep  6 10:13:11 2011 : sent [LCP ConfReq id=0x1    ]
Tue Sep  6 10:13:11 2011 : PPTP port-mapping for en0, interfaceIndex: 0, Protocol: None, Private Port: 0, Public Address: 45f6f181, Public Port: 0, TTL: 0.
Tue Sep  6 10:13:11 2011 : PPTP port-mapping for en0 inconsistent. is Connected: 1, Previous interface: 4, Current interface 0
Tue Sep  6 10:13:11 2011 : PPTP port-mapping for en0 initialized. is Connected: 1, Previous publicAddress: (0), Current publicAddress 45f6f181
Tue Sep  6 10:13:11 2011 : PPTP port-mapping for en0 fully initialized. Flagging up
Tue Sep  6 10:13:14 2011 : sent [LCP ConfReq id=0x1    ]
Tue Sep  6 10:13:17 2011 : sent [LCP ConfReq id=0x1    ]
Tue Sep  6 10:13:20 2011 : sent [LCP ConfReq id=0x1    ]
Tue Sep  6 10:13:23 2011 : sent [LCP ConfReq id=0x1    ]
Tue Sep  6 10:13:26 2011 : sent [LCP ConfReq id=0x1    ]
Tue Sep  6 10:13:29 2011 : sent [LCP ConfReq id=0x1    ]
Tue Sep  6 10:13:32 2011 : sent [LCP ConfReq id=0x1    ]
Tue Sep  6 10:13:35 2011 : sent [LCP ConfReq id=0x1    ]
Tue Sep  6 10:13:38 2011 : sent [LCP ConfReq id=0x1    ]
Tue Sep  6 10:13:41 2011 : LCP: timeout sending Config-Requests
Tue Sep  6 10:13:41 2011 : Connection terminated.
Tue Sep  6 10:13:41 2011 : PPTP disconnecting...
Tue Sep  6 10:13:41 2011 : PPTP clearing port-mapping for en0
Tue Sep  6 10:13:41 2011 : PPTP disconnected

The error seems to be focused around the line, LCP: timeout sending Config-Requests, but I haven’t had any luck in finding troubleshooting information for this. I’ve tried completely deleting the entire VPN “connection” from the Network prefpane and recreating it from scratch. I am certain the connection details are correct because they exactly match what successfully connects from the Win7 machine sitting next to the iMac.

Any suggestions?

Nginx и Client Hello message

Могу ли я как-то в nginx увидеть содержимое поля Client Hello message – cipher suites(это набор доступных шифров которые посылает клиент серверу во время TLS handshake) в логах, например. Смотрел мануал nginx – там про это ничего нет. Я могу это сделать с помощью Wireshark, но нужно именно без использования сторонних программ.

client wants to transfer the large file to the server

Client.py

import socket
import sys

HOST = '192.168.100.232'    # server name goes in here
PORT = 5005


def put(commandName):
    socket1 = socket.socket(socket.AF_INET, socket.SOCK_STREAM)
    socket1.connect((HOST, PORT))
    socket1.send(commandName)
    string = commandName.split(' ', 1)
    inputFile = string[1]
    with open(inputFile, 'rb') as file_to_send:
        for data in file_to_send:
            socket1.sendall(data)
    print 'PUT Successful'
    socket1.close()
    return
msg = raw_input('Enter your name: ')
while(1):
    print '"put [filename]" to send the file the server '
    print '"quit" to exit'
    sys.stdout.write('%s> ' % msg)
    inputCommand = sys.stdin.readline().strip()
    if (inputCommand == 'quit'):
        socket.send('quit')
        break
    else:
        string = inputCommand.split(' ', 1)
        if (string[0] == 'put'):
            put(inputCommand)

Server.py

import socket
import sys
HOST = '192.168.100.232'                 
PORT = 5005

socket = socket.socket(socket.AF_INET, socket.SOCK_STREAM)
socket.bind((HOST, PORT))

socket.listen(1)
while (1):
    conn, addr = socket.accept()
    print 'New client connected ..'
    reqCommand = conn.recv(1024)
    print 'Client> %s' %(reqCommand)
    if (reqCommand == 'quit'):
        break
    else:
        string = reqCommand.split(' ', 1)   #in case of 'put' and 'get' method
        reqFile = string[1] 

        if (string[0] == 'put'):
            with open(reqFile, 'wb') as file_to_write:
                while True:
                    data = conn.recv(1024)
                    if not data:
                        break
                    file_to_write.write(data)
                    file_to_write.close()
                    break
            print 'Receive Successful'

    conn.close()

socket.close()

Both script run: https://i.stack.imgur.com/O7uUs.png

But i receive the corrupt file on the server.can anyone tell me what’s wrong.

EXM Timeout waiting for data from client

We are using Sitecore 9.0 rev. 171219 (9.0 Update-1) with Amazon Simple Email Service as MTA but are experiencing time-outs when we use marketing automation campaigns to send out emails.

We’ve created a simple marketing automation campaign that triggers the same EXM message to the same couple of contacts over and over again after a delay of a couple of minutes, but everly run produces a different outcome. The same MTA is used in our Sitecore Sitecore 8.2 instance and is sending out more than 12.000 emails a day successfully without using marketing automation.

The warning in the Exm.log is not very helpful, but the corresponding error in the Eds.log shows “SmtpCmdResp: 421 Timeout waiting for data from client.

ERROR SendEmailError: ChilkatLog:
  SendEmail:
    DllDate: Aug 30 2017
    ChilkatVersion: 9.5.0.69
    UnlockPrefix: SITECO.EMX082018
    Architecture: Little Endian; 64-bit
    Language: .NET 4.6 VS2017 / x64
    VerboseLogging: 0
    sendEmailInner:
      renderToMime:
        createEmailForSending:
          Auto-generating Message-ID
        --createEmailForSending
        renderToMime: Elapsed time: 0 millisec
      --renderToMime
      sendMimeInner:
        progressTotal: 60865
        ensureSmtpSession:
          ensureSmtpConnection:
            SmtpHost: email-smtp.eu-west-1.amazonaws.com
            SmtpPort: 587
            SmtpUsername: AAAAAAAAAAAAAAAAAAAA
            SmtpSsl: 0
            StartTLS: 1
            smtpConnect:
              smtpHostname: email-smtp.eu-west-1.amazonaws.com
              smtpPort: 587
              connectionIsReady:
                Using existing/open SMTP connection to send email.
              --connectionIsReady
              ConnectionType: SSL/TLS
            --smtpConnect
          --ensureSmtpConnection
        --ensureSmtpSession
        sendSmtpEmail:
          sendNonPipelining:
            sendMailFrom:
              mailFrom: edm@aaaaaa.com
              sendCmdToSmtp:
                SmtpCmdSent: MAIL FROM:
              --sendCmdToSmtp
            --sendMailFrom
            readSmtpResponse:
              SmtpCmdResp: 421 Timeout waiting for data from client.
            --readSmtpResponse
            smtpRset:
              Sending RSET command.
              smtpSendGet2:
                sendCmdToSmtp:
                  SmtpCmdSent: RSET
                --sendCmdToSmtp
                readSmtpResponse:
                  Already received close-notify.
                --readSmtpResponse
              --smtpSendGet2
            --smtpRset
          --sendNonPipelining
        --sendSmtpEmail
      --sendMimeInner
    --sendEmailInner
    Failed.
  --SendEmail
--ChilkatLog

The answer to a similar question for Sitecore 8 with an engagement plan doesn’t seem to solve our issue.

We’ve tried several combinations for the connection pool by lowering the default values, ensured the “NumberThreads” setting is equal to the “maxPoolSize”. Lowered the NumberThreads, maxPoolSize and MaxGenerationThreads settings but the error still occurs.

Which setting can also affect the timeout? Is there any suggestion how we can figure out what goes wrong?

an application (oracle 11g vb.net 2015 and crystal Reports )deploy on client/server

Im developing an application using oracle 11g, vb.net 2015 and Crystal Reports on window 10, i created a package and install an other pc on same network package is running fine but unable to connect to the database… can you give advise/tips how i can deploy the application on client/server, my current network environment windows 10

Connecting a c# desktop client to a web socket [on hold]

I want to create a web socket applicaiton to connect form my desktop applicaitons. But I could not decide which .Net technologies should I use. For example I used SignalR applications before but it connects from a javascript applicaiton.

But my stuation, I need a web applicaiton. When a post request comes to the web application, it will subscribe an event using socket. And my c# desktop applicaiton will handle these socket events.

How can I do this?

cups server error client-error-not-possible ubuntu 18.04

Fresh installation with all the updates suggested, yet I cannot connect to my printer. My previous Ubuntu (16.04) was able to. So it’s not about the printer and whatnot.

I tried literally all options in the GUI, including providing the ppd file. It does not connect to it, giving the same error all the time.

P.S: Yes, I did restart cups as well, that also did not work.

P.S2: I am aware of the existing of similar/same threads. None of the “solutions” worked there.