In a database trigger on event create – How do I reference the created object?

Given the following trigger:

CREATE OR REPLACE TRIGGER 
  TRG_CREATE_TABLE_INITRANS
  AFTER CREATE ON SCHEMA
BEGIN
  IF SYS.DICTIONARY_OBJ_TYPE = 'TABLE' THEN
  exec 'alter table '||||'.'||||' initrans 10'
  END IF;
END;

How do I access the object owner and the object name which triggered the trigger?

Adding vbos to a vao once it has been created

Is it possible to add vbos to vbos after their creation? For example (pseudo-code):

glGenVertexArrays(1, &_vao);
glBindVertexArray(_vao);
// do init stuff
glBindVertexArray(0);

// Much much later in a galaxy far away
glBindVertexArray(_vao);
glGenBuffers(1, &_instance_vbo);
glBindBuffer(GL_ARRAY_BUFFER, _instance_vbo);
glBufferData(GL_ARRAY_BUFFER, sizeof(blee), blee, GL_STATIC_DRAW);
glEnableVertexAttribArray(_vpos_att);
glVertexAttribPointer(_vpos_att, 3, GL_FLOAT, GL_FALSE, 0, (void*)0);

// Draw

So far it hasn’t really worked. Looking at the bound vbos to my vao (using GL_VERTEX_ATTRIB_ARRAY_BUFFER_BINDING) shows no buffers bound. Though that may be another problem altogether.

Is it possible to call Augur functions from my own contract that I created?

For example, I’m trying to call the createYesNoMarket function from my own contract. I supply the universe address on deployment of my contract and I’ve followed the recommended contract call pattern. However, when I deploy and call the wrappedCreate function, I get a gas estimation error on Remix.

Can anyone help with this?

Gas estimation errored with the following message (see below). The
transaction execution will likely fail. Do you want to force sending?

contract Universe {
    function createYesNoMarket(uint256 _endTime, uint256 _feePerEthInWei, address _denominationToken, address _designatedReporterAddress, bytes32 _topic, string _description, string _extraInfo) public payable returns(address);
}

contract AugurWrapper {
    Universe universe;
    constructor(address _a) public{
        universe = Universe(_a);
    }
    function wrappedCreate(uint256 _endTime, uint256 _feePerEthInWei, address _denominationToken, address _designatedReporterAddress, bytes32 _topic, string _description, string _extraInfo) public payable returns(address) {
        return universe.createYesNoMarket(_endTime,_feePerEthInWei,_denominationToken,_designatedReporterAddress,_topic,_description,_extraInfo);       
    }
}

OnMouseDown() and Collision not working for game object created within another game objects script

I have created a game object (Brick) and added a script (BrickScript) to it. Within this script I create a Window game object if a certain condition is satisfied. Please see code below:

if (hasWindow) {
    if (window == null) {
        var size = gameObject.GetComponent().bounds.size;
        window = (GameObject)Instantiate (Resources.Load ("Prefabs/OtherPrefabs/Window"), 
            new Vector3 (transform.position.x + 0.5 * size.x,
                        transform.position.y + 0.5f * size.y, 
                        transform.position.z), 
            Quaternion.Identity));
        window.name = gameObject.name + "Window";
    }
}

 

The Brick and window game objects actually overlap a bit. I realized that when hasWindow = true (the window is created) the condition in the code below is not satisfied and other game objects don’t collide with the Brick. But when hasWindow = false (the window is not created), everything seems to work well. How can I solve this?

void OnMouseDown () {
    if (Input.GetMouseButtonDown(0)) {
        Debug.Log ("touch down");
        hasBeenTouched = true;
    }
}

Thumbnails not created for specific image file extensions (case sensitive)

This is a strange issue. Ever since I installed Drupal 8 (currently 8.6.3) on a managed HostPapa host, I cannot get thumbnails to display for specific file extensions. When I watch the browser dev console, it never creates them under styles. I’ve already cleared the cache from Configuration and rebuilt permissions/checked permissions. I’m running a multi-site setup.

What’s really bizarre is that certain case sensitive extensions work.

Thumbnails that don’t work: .jpg .png

Thumbnails that work: .JPG, .JPEG, .jpeg, .PNG

If I rename the exact same file with a ‘good’ extension, the thumbnail gets created and everything works perfectly. I’m thinking there is some htaccess file somewhere or hardcoded item that blocks jpg/png from being created in styles. I was forced to use the Softaculous Apps Installer which I believe is modifying the drupal install in some strange way and creating this issue.

log message:

Type    page not found
Date    Wednesday, November 14, 2018 - 23:01
User    Anonymous (not verified)
Location    http://example.com/site/sites/example.com/files/styles/thumbnail/public/2018-11/file.png
Referrer    http://example.com/site/node/45/edit?destination=/site/node/45
Message /site/sites/example.com/files/styles/thumbnail/public/2018-11/file.png
Severity    Warning
Hostname    10.0.0.1
Operations  

Update: just to be clear, the issue occurs in all browsers. And if I actually create the file in the styles folder manually, it still doesn’t see it and gives the same error.

Issues with intersecting faces and how to unwrap a maze created from svg file

I’m pretty new to this field.I have used a svg file from maze generator to create a maze. On extruding (and applying solidify modifier), I found that several faces are overlapping and intersecting with each other, which is messing up with the textures. Is there a way to fix this? Can the 2 intersecting objects be merged as 1?highlighted intersecting/overlapping faces and how to unwrap the image?

Thumbnails not created for specific image file extensions (case sensitive) in Drupal 8

This is a strange issue. Ever since I installed Drupal 8 (currently 8.3.6) on a managed HostPapa host, I cannot get thumbnails to display for specific file extensions. When I watch the dev console, it never creates them under styles. I’ve already cleared the cache from Configuration and rebuilt permissions/checked permissions. I’m running a multi-site setup.

What’s really bizarre is that certain case sensitive extensions work.

Thumbnails that don’t work: .jpg .png

Thumbnails that work: .JPG, .JPEG, .jpeg, .PNG

If I rename the exact same file with a ‘good’ extension, the thumbnail gets created and everything works perfectly. I’m thinking there is some htaccess file somewhere or hardcoded item that blocks jpg/png from being created in styles. I was forced to use the Softaculous Apps Installer which I believe is modifying the drupal install in some strange way and creating this issue.

log message:

Type    page not found
Date    Wednesday, November 14, 2018 - 23:01
User    Anonymous (not verified)
Location    http://example.com/site/sites/example.com/files/styles/thumbnail/public/2018-11/file.png
Referrer    http://example.com/site/node/45/edit?destination=/site/node/45
Message /site/sites/example.com/files/styles/thumbnail/public/2018-11/file.png
Severity    Warning
Hostname    10.0.0.1
Operations