Data visualization and device management

I’m looking for a solution to manage (virtual) devices and visualize data.

I have a lot of timeseries data grouped by sessions and devices stored in a database. That data is coming from multiple physical sensor devices.

Now I am looking for a tool where a customer can select a device from something like a hierachical device tree. After selecting a device he should be able to select a session. Then he should get all related sensor values displayed in a chart.

The tool/platform should be able to pull (selected) data from a web service. The tool should not store the pulled data in a database. And I want to be able send commands to the webservice to set some configurations or whatever.

The most IoT platforms don’t pull the data, you have to push the data to these platforms. And they have normally their own embedded database. I dont want to analyze the data, so I dont need complex analytical features. I just want to select a device and a session and get the data from my existing database/webservice.

Does anybody know a Dashboard/Device Management tool/platform?

All topic

Medical Device – multiple FEI numbers associated with a single 510(k) number

In the device 510(k) endpoint data (downloadable JSON file on OpenFDA), a single 510(k) number is associated with multiple FDA Establishment Identification (FEI) numbers, and I am not being able to figure out how those multiple FEI numbers are associated with a single 510(k) number. I would greatly appreciate your help.

Below are some more details on how I collected/parsed the data and an example.

I have downloaded the device 510(k) endpoint data (JSON file) from the OpenFDA website (link here), and parsed it in R software, using the “jasonlite” package (R code for importing the json file below):

library(readr)
library(jsonlite)
data_flat_510k <- fromJSON('device-510k-0001-of-0001.json', flatten = TRUE)

The device 510(k) endpoint data has 29 fields (i.e., columns), including 510(k) number, device name, applicant name and address, etc. One of these fields is "openfda.fei_number" which is a "list" of the FEI numbers associated with each 510(k) number.

For example, the list of FEI numbers associated with a single 510(k) number "K840424" is: "1048014, 3002808374, 3003915875, 3009211636, 1000587249, 2518902, 1000138054, 1282497"

So, the 510(k) number "K840424" has 8 FEI numbers. If I look this 510(k) number up in the Device Registrations and Listings database (also available/downloadable on OpenFDA), it shows only one medical device establishment, and thus, only one FEI number (which is one of the above listed FEI numbers).

Again, I can't figure out how these FEI numbers are associated with this single 510(k) number, and I would appreciate your help!

All topic

Routing asio soundcard output to a PC input device

I’m using an asio sound card with Ableton live, and would like to route audio input through Ableton and then into another application such as Discord or OBS.

I know there’s a non-asio solution to do this using vb-audio virtual cables, but this adds over 100ms of input latency, making it nearly impossible to monitor myself and speak well at the same time.

Are there any solutions that allow me to take advantage of asio input/output processing? If there are no software solutions, are there any hardware solutions?

All topic

UV4L can not be started : [core] No device detected

I was using uv4l package for streaming.suddenly it stopped working when I want run this command for example :
“sudo uv4l -nopreview —auto-video_nr —driver raspicam —encoding mjpeg —width 640 —height 480 —framerate 20 —server-option ‘–port=9090’ —server-option ‘–max-queued-connections=30’ —server-option ‘–max-streams=25’ —server-option ‘–max-threads=29′”

it return with this error :
[core] No device detected

by the way uv4l is running background when it Raspberry restarts on boot and it’s available on port 8080 and streams the video on http://raspberryIp:8080/stream
but it seem I can not start another server
Thanks in advance

All topic

arabic support (RTL language) for delphi – multi device application

I’m shocked when i realized that Delphi 10.2 is NOT supporting to Arabic (RTL language) for Delphi – multi device application!!
Is there anyway to solve this issue?

All topic

Bringing up interface en0: Device does not seem to be present, delaying initialization.

This is my /etc/sysconfig/network-scripts/ifcfg-eth0 in my CentOS 6.9:

enter image description here

code is :

DEVICE=eth0
HWADDR=00:15:5D:E0:1C:02
TYPE=Ethernet
UUID=xxxx
ONBOOT=no
NM_CONTROLLED=yes
BOOTPROTO=static
IPADDR=43.224.12.3
NETMASK=255.255.255.248
GATEWAY=43.224.12.1
DNS1=8.8.8.8
DNS2=8.8.0.0

but when I restart the network, there get error:

enter image description here

Bringing up interface en0: Device does not seem to be present, delaying initialization.

But my /etc/sysconfig/network-scripts/ifcfg-en0 is a empty file.

I also tried check the /etc/udev/rules.d/70-persistent-net.rules, there is only eth0 in it.

All topic

Strongswan creating TUN device : ipsec0

Running strong swan server in 172.27.1.159 IP.
Running strong swan client in 172.27.1.152 IP, then created namespace in 172.27.1.152 IP that namespace has 172.27.1.153 IP.
Then strong swan creating TUN device : ipsec0 in namespace, to that interface strong swan server is associating virtual IP address.
when we ping from namespace(172.27.1.153) to outside. Strong swan server is not forwarding packet outside network.

All topic

Windows 10 pro 64 bit OS: Phoenix OS booting error: device descriptor read/64, error -71

I have Windows 10 pro 64 bit OS, with Intel core 2 duo T5870 processor 2.0 ghz speed and 2 Gb ram. I tried to install phoenix OS but it says that I have 32 bit OS so download x86 phoenix OS but instead I Downloaded phoenix OS 3.0.5 and at the time of booting it showed an error that:

[.      0.134273]  ACPI Exception: AE_NOT_FOUND, Evaluating  _PRS (20170728/pci_link-176)
[.      1.492032] usb 4-2: device descriptor read/64, error -71
Detecting Phoenix OS...found at /dev/sda5

All topic

In G Suite, can an administrator unable sync for a specific device of a user?

In G Suite can an administrator or super admin turn off sync for a specific device of a user, (not permanently disable)? For example like a device does not sync photos into drive etc but the user can later on enable it.

All topic

In G Suite an administrator unable sync for a specific device of a user?

In G Suite can an administrator or super admin turn off sync for a specific device of a user, (not permanently disable)? For example like a device does not sync photos into drive etc but the user can later on enable it.

All topic