Alt+Num pad stopped working for special characters

This has happened on both my machines, albeit a little bit differently. On my laptop, which is my main concern right now, it has stopped working completely. Alt+Num pad for typing special characters does absolutely nothing. On my desktop, it still works but I have to hit space after typing the code, which never was the case before.

But more importantly, I need to get my laptop going. I imagine this was some cat-related thing, where they hit some combination to turn it off but I can’t for the life of me figure out how to get it back.

Has anyone had this happen and found a solution? Thanks in advance!

All topic

Sudo has stopped working : sudo: error in /etc/sudo.conf, line 0 while loading plugin `sudoers_policy’

I have a weird issue with my Raspberry pi – sudo has stopped working. Every time I try to run a command using sudo, i get this:

sudo: error in /etc/sudo.conf, line 0 while loading plugin `sudoers_policy'
sudo: unable to load /usr/lib/sudo/sudoers.so: (null) 
sudo: fatal error, unable to load plugins

Commands without sudo seem to work okay. The file /etc/sudo.conf doesn’t exist at all.

This is the system info:

Linux raspberrypi 4.4.21-v7+ #911 SMP Thu Sep 15 14:22:38 BST 2016 armv7l GNU/Linux

Is there a way of fixing this, ideally without formatting the SD card/reinstalling?

All topic

yum stopped wokring on my ec2 instance

I have an EC2 instance on which I was trying to install spark.I removed python2 from the system by mistake and nothing seems to work now including yum,python etc..
I am really new to Linux and stuck for two days now trying to figure out what is happening.

Can someone help me showing how to fix the broken python2 version in my ec2 Linux(Centos).

Below is the error I get when I try to use yum

-bash: /usr/bin/yum: /usr/bin/python2.7: bad interpreter: No such file or directory

I guess, I deleted a rrquired version of python.

All topic

Xcode stopped detecting SVN repository changes after installing other version controlling apps

Last week I installed Source Tree and Github for Dekstop version controlling apps on my Mac, prior to that I am also accessing our companies SVN repository server to contribute on our projects. While I have not installed other apps my SVN repo changes was detectable by Xcode meaning I can push/pull and commit directly from the Xcode.

But after installing those apps Xcode stopped detecting the changes and I feel lost with this.

System Configurations: macOS High Sierra 10.13.6 (17G65)
Xcode Version: 10.0

Any Apple Xcode’s expert can help me with this?

All topic

Patch stopped Instances using AWS system manager document

I want to Patch stopped Instances using AWS system manager document. To do that, I try to create my own SSM document, which copy the following pre-existed SSM documents to my mainSteps as follows:

  1. copy and paste the steps of SSM document: AWS-StartEC2Instance;

  2. copy and paste the steps of SSM document AWS-RunPatchBaseline;

  3. copy and paste the steps of AWS-StopEC2Instance;

However, the above three SSM documents have different SSM document types, 1&3 are Automation document type which has “schemaVersion”: “0.3”, while 2. uses command document type “schemaVersion”: “2.2”. I do not know how to make use of them.

How do I create my own document from the existing SSM documents?
or do I have to manually create everything myself without refer to the pre-existing documents?

My user case is: I have EC2s which are running or stopped. for the EC2s which are running, patch them; for the EC2s which have stopped, start, patch them and then stop them.

All topic

QGIS installation has stopped running when startup?

My laptop is Windows 10 and I have installed QGIS 2.14 64bit twice; because due to some problems I uninstalled the software and reinstalled it. Now: “qgis has stopped running when startup”

I have searched for solutions on GIS SE and here is what I have done:

  1. I delete the .qgis2 but it fails;
  2. I tried to run qgis-ltr-bin.bat as “gis.stackexchange.com” guides but it fails;
  3. I tried to uninstall and delete everything about QGIS in C: drive as “gis.stackexchange.com” guides but it fails;
  4. I tried to install other software like 2.18 64bit but it also fails.

All topic

Link2SD suddenly stopped working properly

I installed LineageOS 14.1 on my Huawei P9 Lite about a week ago. Shortly after I installed Link2SD to convert some apps from user into system apps. During this time I was setting up my phone, installing apps, configuring them and changing system settings, nothing too special, but then I had to use the application once again except this time to freeze an app and it failed. It shows this error when trying to freeze/unfreeze & convert an app:

error

I tried many things like

  • Wiping the caches
  • Flashing the OS image (without wiping)
  • Flashing AddonSU
  • Reinstalling Link2SD
  • Converting Link2SD into system app

But nothing helped. Does anyone have an idea about what’s wrong? The only thing that might have caused this were probably my attempts at installing Google Camera, because I had to install many versions, convert them into system apps and also flash a “front camera fix” zip through TWRP.

All topic

Messages app on my Macbook Pro stopped sending to Android

The Messages app on my Macbook Pro (running High Sierra) suddenly stopped sending text messages to Android devices. I can still send texts to Android users from my iPhone without a problem, but when sending texts from the Messages app on my Macbook Pro it will not send to Android devices. It just started doing this out of the blue yesterday. I have not had an issue until then. And I have not made any updates to the Mac or the iPhone OSs in that time that might cause the problem, but I did install Microsoft Office 2018 on the Mac. Cellular data is turned on on my iPhone as is Send as SMS.

All topic

Create thread for piece of code that can be stopped in the middle (Android Studio)

I’m new to android development and I want to create a button to start a tempo beats (like metronome) and stop when clicked again (one button for both start and stop).

When I click the button it starts playing 5 sounds one after another in one second delay and repeating that 5 sounds loop until I press the button again to stop.

My issue is that the whole system is kind of “locked” until all the 5 sounds played (can’t press volume up or down and the stop button actually works only after the 5 sounds finished).

So I want to create a thread in order to run the 5 sounds and when I press the button again, I want the thread to stop immediately. I tried without success, so any help would be great.

Here is the onClick method:

public boolean tempoOn = false; // global

public void clickHandlerStartTempo(View view) {
    if (!tempoOn) {
        Toast toast = Toast.makeText(getApplicationContext(), "Start Tempo!", Toast.LENGTH_SHORT);
        toast.show();
        tempoOn = true;
        final Handler handler = new Handler();
        final int delay = 1000; //milliseconds

        handler.postDelayed(new Runnable(){
            public void run(){
                if (tempoOn) {
                    playSound(0);
                    SystemClock.sleep(1000);
                    playSound(1);
                    SystemClock.sleep(1000);
                    playSound(1);
                    SystemClock.sleep(1000);
                    playSound(1);
                    SystemClock.sleep(1000);
                    playSound(1);
                    handler.postDelayed(this, delay);
                }
            }
        }, delay);
    } else {
        Toast toast = Toast.makeText(getApplicationContext(), "Stop Tempo!", Toast.LENGTH_SHORT);
        toast.show();
        tempoOn = false;
    }

}

Thanks a lot.

All topic

Stopped user manager for uid 121

I ran into another ubuntu disaster.

The OS didn’t boot. Last message was: “started user manager for uid 121”.

Reading up on this all solutions pointed to the crap nvidea drivers. I’ve had problems with them before so that seemed likely.

Ubuntu version: 18.04

All topic