Ubuntu 14.04 Asus G550JK SonicMaster External Subwoofer not working

I have bought Asus G550JK laptop(G version of N550) and installed Ubuntu 14.04 on it. I’m just a beginner in using Ubuntu, but I managed to make everything work fine except the external SonicMaster subwoofer. There is no 2.1 option in Sound Settings, I think Ubuntu doesn’t see the subwoofer. I tried many solutions, but I only managed to enable 2.1 settings with subwoofer, but when I check the sound I can only hear some noises from the laptop, not the subwoofer.

I have added this at the end of the file:

/etc/modprobe.d/alsa-base.conf

options snd-hda-intel model=asus-mode4

but it doesn’t change anything.

Also, adding

[Mapping analog-surround-21]

device-strings = surround40:%f

channel-map = front-left,front-right,lfe,lfe

paths-output = analog-output analog-output-speaker

priority = 7

direction = output

to the file:

/usr/share/pulseaudio/alsa-mixer/profile-sets/extra-hdmi.conf

doesn’t help.

Of course I changed the line in

/etc/pulse/daemon.conf

to

enable-lfe-remixing = yes

but all in all, it leads to nothing. I managed to enable 2.1 by adding the line:

load-module module-combine channels=3 channel_map=front-left,front-right,lfe

to the file:

/etc/pulse/default.pa

but, as I said, during the subwoofer check in Sound Settings I only heard some noises from the laptop.

Have you got any idea how to get it working? Thanks for any help. 🙂

Leave a Reply

Your email address will not be published. Required fields are marked *